use strict;
my $str = 'The quick brown fox jumps over the lazy dog';
my $regex = qr/(.*brown )(?:[^l]*)(.*)/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";