#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]+\d*$"
Local $sString = "a" & @CRLF & _
"a1" & @CRLF & _
"abc12" & @CRLF & _
"ab123" & @CRLF & _
"abcdsdfsdf123" & @CRLF & _
"" & @CRLF & _
"abcd323sdfsdf123" & @CRLF & _
"a1b2c1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")