$re = '/^[a-z]+\d*$/m';
$str = 'a
a1
abc12
ab123
abcdsdfsdf123
abcd323sdfsdf123
a1b2c1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);