package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+\d*$`)
var str = `a
a1
abc12
ab123
abcdsdfsdf123
abcd323sdfsdf123
a1b2c1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}