const regex = /^[a-z]+\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+\\d*$', 'gm')
const str = `a
a1
abc12
ab123
abcdsdfsdf123
abcd323sdfsdf123
a1b2c1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}