import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!([^\\r\\n;]*);(?:(b|d))(?:;|$)).*\\R";
final String string = "\n"
+ "a;; z\n"
+ "toy;d;hh \n"
+ "toy\n"
+ ";b;;jj\n"
+ "z;\n"
+ "d;23\n"
+ "d;23td\n"
+ ";;io;\n"
+ "b y;b;12\n"
+ "z\n"
+ "a;b;bb;;;34\n"
+ "z";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}