use strict;
my $str = '
a;; z
toy;d;hh
toy
;b;;jj
z;
d;23
d;23td
;;io;
b y;b;12
z
a;b;bb;;;34
z';
my $regex = qr/^(?!([^\r\n;]*);(?:(b|d))(?:;|$)).*\R/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";