const regex = /^(?!([^\r\n;]*);(?:(b|d))(?:;|$)).*\R/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!([^\\r\\n;]*);(?:(b|d))(?:;|$)).*\\R', 'mg')
const str = `
a;; z
toy;d;hh
toy
;b;;jj
z;
d;23
d;23td
;;io;
b y;b;12
z
a;b;bb;;;34
z`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);