$re = '/^(?!([^\r\n;]*);(?:(b|d))(?:;|$)).*\R/m';
$str = '
a;; z
toy;d;hh
toy
;b;;jj
z;
d;23
d;23td
;;io;
b y;b;12
z
a;b;bb;;;34
z';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;