#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/test/([^/\n]+)/([^/\n]+)/?$"
Local $sString = "/test/randomstring1/randomstring2" & @CRLF & _
"/test/randomstring1/randomstring2/" & @CRLF & _
"/test/randomstring1/randomstring2/randomstring3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")