re = /^\/test\/([^\/\n]+)\/([^\/\n]+)\/?$/m
str = '/test/randomstring1/randomstring2
/test/randomstring1/randomstring2/
/test/randomstring1/randomstring2/randomstring3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end