$re = '~^/test/([^/\n]+)/([^/\n]+)/?$~m';
$str = '/test/randomstring1/randomstring2
/test/randomstring1/randomstring2/
/test/randomstring1/randomstring2/randomstring3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);