package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/test/([^/\n]+)/([^/\n]+)/?$`)
var str = `/test/randomstring1/randomstring2
/test/randomstring1/randomstring2/
/test/randomstring1/randomstring2/randomstring3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}