using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^<>]*\bname=""[^""]*""[^<>]*>|([_!=+])";
string input = @"cat_dog_ !mouse= <test name=""Jake_Russell!"" a=1> gog+cat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}