$re = '/<[^<>]*\bname="[^"]*"[^<>]*>|([_!=+])/m';
$str = 'cat_dog_ !mouse= <test name="Jake_Russell!" a=1> gog+cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);