re = /<[^<>]*\bname="[^"]*"[^<>]*>|([_!=+])/m
str = 'cat_dog_ !mouse= <test name="Jake_Russell!" a=1> gog+cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end