#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]{2}39\.[a-z]{4} \(([\d.]+)"
Local $sString = "livebox.home (192.168.1.1)" & @CRLF & _
"set-top-box41.home (192.168.1.10)" & @CRLF & _
"pc38.home (192.168.1.11)" & @CRLF & _
"pc43.home (192.168.1.12)" & @CRLF & _
"pc39.home (192.168.1.15)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")