import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]{2}39\\.[a-z]{4} \\(([\\d.]+)";
final String string = "livebox.home (192.168.1.1)\n"
+ "set-top-box41.home (192.168.1.10)\n"
+ "pc38.home (192.168.1.11)\n"
+ "pc43.home (192.168.1.12)\n"
+ "pc39.home (192.168.1.15)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}