const regex = /^[a-z]{2}39\.[a-z]{4} \(([\d.]+)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]{2}39\\.[a-z]{4} \\(([\\d.]+)', 'm')
const str = `livebox.home (192.168.1.1)
set-top-box41.home (192.168.1.10)
pc38.home (192.168.1.11)
pc43.home (192.168.1.12)
pc39.home (192.168.1.15)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}