re = /^[a-z]{2}39\.[a-z]{4} \(([\d.]+)/m
str = 'livebox.home (192.168.1.1)
set-top-box41.home (192.168.1.10)
pc38.home (192.168.1.11)
pc43.home (192.168.1.12)
pc39.home (192.168.1.15)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end