#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\+994|0)(?:51|50|55|70|77|99)[^\d]{0,2}[2-9][0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]"
Local $sString = "" & @CRLF & _
"+994509793270" & @CRLF & _
"0509793270" & @CRLF & _
"+994708769006" & @CRLF & _
"0708769006" & @CRLF & _
"+994559793270" & @CRLF & _
"0559793270" & @CRLF & _
"+994519793270" & @CRLF & _
"0519793270" & @CRLF & _
"+994999793270" & @CRLF & _
"0999793270" & @CRLF & _
"+994779793270" & @CRLF & _
"0779793270" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")