package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\+994|0)(?:51|50|55|70|77|99)[^\d]{0,2}[2-9][0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]`)
var str = `
+994509793270
0509793270
+994708769006
0708769006
+994559793270
0559793270
+994519793270
0519793270
+994999793270
0999793270
+994779793270
0779793270
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}