import re
regex = re.compile(r"(?:\+994|0)(?:51|50|55|70|77|99)[^\d]{0,2}[2-9][0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]", flags=re.MULTILINE)
test_str = ("\n"
"+994509793270\n"
"0509793270\n"
"+994708769006\n"
"0708769006\n"
"+994559793270\n"
"0559793270\n"
"+994519793270\n"
"0519793270\n"
"+994999793270\n"
"0999793270\n"
"+994779793270\n"
"0779793270\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")