// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\+994|0)(?:51|50|55|70|77|99)[^\d]{0,2}[2-9][0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]").unwrap();
let string = "
+994509793270
0509793270
+994708769006
0708769006
+994559793270
0559793270
+994519793270
0519793270
+994999793270
0999793270
+994779793270
0779793270
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}