using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[ABCEHKMOPTXY][0-9]{3}[ABCEHKMOPTXY]{2}\b";
string input = @"A000BC T599OX Y200CE E666MN
S000VC W599JX U200SD Q666ZA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}