// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[ABCEHKMOPTXY][0-9]{3}[ABCEHKMOPTXY]{2}\b").unwrap();
let string = "A000BC T599OX Y200CE E666MN
S000VC W599JX U200SD Q666ZA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}