import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[ABCEHKMOPTXY][0-9]{3}[ABCEHKMOPTXY]{2}\\b";
final String string = "A000BC T599OX Y200CE E666MN\n"
+ "S000VC W599JX U200SD Q666ZA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}