re = /\b[ABCEHKMOPTXY][0-9]{3}[ABCEHKMOPTXY]{2}\b/m
str = 'A000BC T599OX Y200CE E666MN
S000VC W599JX U200SD Q666ZA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end