#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[a-zA-Z\d]{4,7}$)[a-zA-Z]*\d{4}[a-zA-Z]*$"
Local $sString = "abc1234" & @CRLF & _
"ab1234" & @CRLF & _
"1234" & @CRLF & _
"1234abd" & @CRLF & _
"" & @CRLF & _
" Invalid input: " & @CRLF & _
"1a1234" & @CRLF & _
"12345" & @CRLF & _
"a1s1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")