const regex = /^(?=[a-zA-Z\d]{4,7}$)[a-zA-Z]*\d{4}[a-zA-Z]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[a-zA-Z\\d]{4,7}$)[a-zA-Z]*\\d{4}[a-zA-Z]*$', 'gm')
const str = `abc1234
ab1234
1234
1234abd
Invalid input:
1a1234
12345
a1s1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}