re = /^(?=[a-zA-Z\d]{4,7}$)[a-zA-Z]*\d{4}[a-zA-Z]*$/m
str = 'abc1234
ab1234
1234
1234abd
Invalid input:
1a1234
12345
a1s1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end