$re = '/^(?=[a-zA-Z\d]{4,7}$)[a-zA-Z]*\d{4}[a-zA-Z]*$/m';
$str = 'abc1234
ab1234
1234
1234abd
Invalid input:
1a1234
12345
a1s1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);