#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "data-thumb-bg="([^"]+)""
Local $sString = "<div data-thumb-bg="photo.jpg">Foo Bar</div>"
Local $sSubst = "style="background-image: url(\1);""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)