re = /data-thumb-bg="([^"]+)"/
str = '<div data-thumb-bg="photo.jpg">Foo Bar</div>'
subst = 'style="background-image: url(\\1);"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result