import re
regex = re.compile(r"data-thumb-bg=\"([^\"]+)\"")
test_str = "<div data-thumb-bg=\"photo.jpg\">Foo Bar</div>"
subst = "style=\"background-image: url(\\1);\""
result = regex.sub(subst, test_str)
if result:
print(result)