$re = '/data-thumb-bg="([^"]+)"/';
$str = '<div data-thumb-bg="photo.jpg">Foo Bar</div>';
$subst = "style=\"background-image: url(\1);\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;