package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)\{{2}(([a-z]+\|.+)|([a-z\_]+))\}{2}`)
var str = `<p>{{youtube|id=ykwqXuMPsoc&width=560&height=315}}</p>
<p>{{email_company}}</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}