re = /\{{2}(([a-z]+\|.+)|([a-z\_]+))\}{2}/
str = '<p>{{youtube|id=ykwqXuMPsoc&width=560&height=315}}</p>
<p>{{email_company}}</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end