import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{{2}(([a-z]+\\|.+)|([a-z\\_]+))\\}{2}";
final String string = "<p>{{youtube|id=ykwqXuMPsoc&width=560&height=315}}</p>\n"
+ "<p>{{email_company}}</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}