$re = '/\{{2}(([a-z]+\|.+)|([a-z\_]+))\}{2}/U';
$str = '<p>{{youtube|id=ykwqXuMPsoc&width=560&height=315}}</p>
<p>{{email_company}}</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);