# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-[AR](?:-OK)?/$1/gm;t' <<< "Word1-A-OK
Word2-Sample-R-OK
Word3-A"