#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-[AR](?:-OK)?"
Local $sString = "Word1-A-OK" & @CRLF & _
"Word2-Sample-R-OK" & @CRLF & _
"Word3-A"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)