const regex = /-[AR](?:-OK)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-[AR](?:-OK)?', 'gm')
const str = `Word1-A-OK
Word2-Sample-R-OK
Word3-A`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);