using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-[AR](?:-OK)?";
string substitution = @"$1";
string input = @"Word1-A-OK
Word2-Sample-R-OK
Word3-A";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}