using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d){4}";
string input = @"IT Group 2019 Teknik Eğitim İçeriği ve Takvimini’’, ingilizce eğitim desteği alma koşullarımızı sizlerle daha önce paylaşmıştık. Öncelikle eğitim süreçlerimize gösterdiğiniz ilgi için çok teşekkür ederim. Teknik eğitimlerimiz bir taraftan devam ederken, ingilizce eğitim taleplerini ileten arakadaşlarımız ile bire bir görüşmelerimizi sürdürüyoruz.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}