import Foundation
let pattern = #"(\d){4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"IT Group 2019 Teknik Eğitim İçeriği ve Takvimini’’, ingilizce eğitim desteği alma koşullarımızı sizlerle daha önce paylaşmıştık. Öncelikle eğitim süreçlerimize gösterdiğiniz ilgi için çok teşekkür ederim. Teknik eğitimlerimiz bir taraftan devam ederken, ingilizce eğitim taleplerini ileten arakadaşlarımız ile bire bir görüşmelerimizi sürdürüyoruz."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)