re = /(\d){4}/m
str = 'IT Group 2019 Teknik Eğitim İçeriği ve Takvimini’’, ingilizce eğitim desteği alma koşullarımızı sizlerle daha önce paylaşmıştık. Öncelikle eğitim süreçlerimize gösterdiğiniz ilgi için çok teşekkür ederim. Teknik eğitimlerimiz bir taraftan devam ederken, ingilizce eğitim taleplerini ileten arakadaşlarımız ile bire bir görüşmelerimizi sürdürüyoruz.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end