package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d){4}`)
var str = `IT Group 2019 Teknik Eğitim İçeriği ve Takvimini’’, ingilizce eğitim desteği alma koşullarımızı sizlerle daha önce paylaşmıştık. Öncelikle eğitim süreçlerimize gösterdiğiniz ilgi için çok teşekkür ederim. Teknik eğitimlerimiz bir taraftan devam ederken, ingilizce eğitim taleplerini ileten arakadaşlarımız ile bire bir görüşmelerimizi sürdürüyoruz.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}