const regex = /(?<!"\s)#([0-9\p{L}]+)(?=[\s,!?.\n][^"]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!"\\s)#([0-9\\p{L}]+)(?=[\\s,!?.\\n][^"]|$)', 'gm')
const str = `I enjoy #action movies! #Action
movies are #cool.
Color #000000; #ffffff; work fine
<div style=" #something "> - works
#action " - works
" #action - doesn't work
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}