re = /(?<!"\s)#([0-9\p{L}]+)(?=[\s,!?.\n][^"]|$)/m
str = 'I enjoy #action movies! #Action
movies are #cool.
Color #000000; #ffffff; work fine
<div style=" #something "> - works
#action " - works
" #action - doesn\'t work
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end